وصله امنیتی ضروری برای استفاده از SSL در سرورهای سازمانی

 | تاریخ ارسال: ۱۳۹۷/۷/۲۸ | 
در صورتی که از ssl در سرور سازمانی خود استفاده می کنید، لازم است برای جلوگیری از حمله heartbleed، وصله امنیتی SSL را روی سرور نصب کنید. در صورتی که امکان login به سرور و اجرای دستور را دارید از راهنما و دستورات زیر کمک بگیرید. در غیر این صورت می توانید برای بروزرسانی با شرکت مذاکره نمایید:
 
https://www.apachefriends.org/blog/heartbleed-bug.html
برای مشاهده نسخه سیستم عامل سرور از دستور زیر استفاده کنید:
uname -a
دستورات لازم در صورت استفاده از سرورهای 64 بیتی:
(توجه: نصب نسخه اشتباه منجر به توقف کار سرور خواهد شد)
mkdir /root/xmpup/
cd /root/xmpup/
wget http://yektaweb.ir/0attach/xampp-opensslfix-linux-x64.tar.gz
tar -xzf xampp-opensslfix-linux-x64.tar.gz -C /root/xmpup/

/opt/lampp/xampp stopapache
mkdir -p /opt/lampp/opensslbackup/
sudo mv /opt/lampp/lib/libssl* /opt/lampp/opensslbackup/
sudo mv /opt/lampp/lib/libcrypto* /opt/lampp/opensslbackup/
sudo mv /opt/lampp/lib/engines /opt/lampp/opensslbackup/
sudo mv /opt/lampp/bin/openssl /opt/lampp/opensslbackup/
cp -rp /root/xmpup/xampp-opensslfix-linux-x64/lib/* /opt/lampp/lib/
cp -rp /root/xmpup/xampp-opensslfix-linux-x64/bin/openssl /opt/lampp/bin/
/opt/lampp/xampp startapache
این بروزرسانی در سرورهای اصلی شرکت که مسئولیت آنها با شرکت می باشد در همان زمان انتشار باگ به صورت رایگان انجام شده است.